Categories
Uncategorized

FastCGI

I spent a little while yesterday attempting to work out how to get FastCGI installed. Unfortunately, because I’m using Apache 2.2, this wasn’t straightforward. In fact, I’d pretty much given up. Later on, I found this patch on the fastcgi-devel list, which purports to work (and looks like it will, given my experiences yesterday).

All this is just so that I can sensibly run Typo, a rails app. There are other ways to do it, but they’re less preferrable. I could use plain CGI, but that’s dog-slow. I could set up lighttpd, but I’d rather not, seeing as I’m already running Apache for so many other services. I suppose that I could run the standalone script/server tool and use mod_proxy to connect to it. But I that means that I then have to ensure that the process stays up the whole time and gets started correctly. Overall, FastCGI seems like the best choice.

So, today I’ll have a go at plumbing that patch into the FreeBSD port.

5 replies on “FastCGI”

dominic…. i hear you.. i’ve tried about fastcgi for 3 days straight and i’ve just about had it. although i was able to get apache + scgi up and running, I then couldn’t figure out how to v-host with the scgi service in windows.. alas i revert back to trying to get fastcgi going. If you discover anything please alert a fellow soilder in the same battle.

Leave a Reply to Ken Cancel reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s